Schweiz Schweiz

Warum erhalte ich die Warnung "Zend OPcache API is restricted"

Wir setzen für unsere Server "OpCode Cache" ein, damit die Geschwindigkeit von PHP erhöht wird.

Hierzu wurden die folgenden PHP Funktionen deaktiviert, da es ansonsten möglich ist fremde Dateien anderer Kunden aus dem Cache oder sogar den kompletten Cache zu löschen.

opcache_compile_file()
opcache_get_configuration()
opcache_get_status()
opcache_invalidate()
opcache_reset()

Aufgrund dessen kann es sein, falls Ihr eingesetztes System eine der o.g. Funktionen nutzt, dass Sie die folgende Warnung erhalten:

Warning: Zend OPcache API is restricted by "restrict_api" configuration directive

Wenn Sie so eine Meldung erhalten kontaktieren Sie bitte den easyname Support